send help

Discussion in 'General Server Chat' started by NeverReady, Jan 23, 2017.

  1. NeverReady

    NeverReady [BB] Admin Admin

    Joined:
    Jul 19, 2016
    Messages:
    150
    Likes Received:
    148
    So I reset my computer two days ago and now my game messes up every time I log on the server for the first time. My items are missing, my status, plat, titles, basically everything. I have to wait until map change for it to fix itself. I was wondering if this had ever happened before and hoped someone could give a suggestion as to what bork here. Also, on another note;

    http://imgur.com/YH2rThV

    When anything involving cubes occurs, like hitting halfway in a map or completing a map, it just gives me that statement as shown in the linked picture.
    "Something has gone wrong here. Please contact an admin."

    If you know anything to fix this or whatever the problem might be, do tell pls.
     
  2. Kaiden

    Kaiden Administrator Community Manager

    Joined:
    Feb 13, 2008
    Messages:
    4,615
    Likes Received:
    519
    Will be one for @Teddi when he wakes up in like 9 hours :(
     
  3. NeverReady

    NeverReady [BB] Admin Admin

    Joined:
    Jul 19, 2016
    Messages:
    150
    Likes Received:
    148
    I'm willing to wait. Just want it fixed. :(

    sadness ensues.
     
  4. Teddi

    Teddi Well-Known Member Bear

    Joined:
    Jul 21, 2007
    Messages:
    9,439
    Likes Received:
    799
    Currently investigating it, pulling stuff up in the admin slack
     
  5. Teddi

    Teddi Well-Known Member Bear

    Joined:
    Jul 21, 2007
    Messages:
    9,439
    Likes Received:
    799
    This is currently only a theory because I can't really test until you're around.

    For whatever reason when your GMod is loading in, your client is no longer running specific functions (or something is somehow getting in the way of it) and you never actually request your account. As a result of this you don't ever receive anything and I'm also willing to bet this is the first time you join, usually after you've just opened GMod. Every other time it probably works if I was to guess right?

    If this is the case, it would explain why a rejoin or a changelevel fixes it - because you've precached all the data at this point and you then call the appropriate function. The real trick is going to be how to fix this; we have a players client request the data when they're ready (InitPostEntity) hook, but if this is somehow taking too long or too quick maybe, it could be upsetting the balance somehow.
     
  6. Teddi

    Teddi Well-Known Member Bear

    Joined:
    Jul 21, 2007
    Messages:
    9,439
    Likes Received:
    799
    Solution for anyone wondering was to verify the GMod cache.
     
    NeverReady likes this.